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Learning Resources – Self-Testing Forms in Excel 

You can use forms in Microsoft Excel to develop a self-testing learning resource 

similar to this example below. 

Open up Microsoft Excel and save the spreadsheet. 

Click on Sheet 2 at the bottom of the spreadsheet and type in the following text. 

If the cell columns aren’t wide enough for the text, double-clicking on the line 
between the columns makes the columns automatically as wide as the text. 

You need to give a number to each possible answer plus a blank answer to appear 

when the student first opens the spreadsheet (in column B), as Excel compares 

numbers rather than text.  As the user changes the values in the box that you will 
set up, the number in user choice cells (C9 and D9) will change i.e. if the student 

picks “fille”, the user choice will change to 4. 

Cells C10 and D10 will show the difference between the number of the correct 
answer and the number of the answer chosen by the user. 

In cell  C10 type in =C9-C8 
In cell D10 type in =D9-D8 
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Cell C12 sets up the message which will be shown when the user chooses the 

correct answer and the message which will be shown when the user chooses the 
incorrect answer. 

In cell C12, type in the following IF statement:  =IF(C9=1,"Please choose your 

answer from the list",IF(C9=””,”Please choose your answer from the 
list”,IF(C10=0,"Well done","Sorry, that's wrong"))) 

This means that if the user chooses the first choice on the list (shown in C9) which 
is blank, which should automatically appear first, the message “Please choose your 

answer from the list” will appear.  If there is the difference in C10 between the user 

choice and the correct number is 0, then the message shown will be “Well done”.  If 
the difference is anything other then 0, the message will be “Sorry that’s wrong”, 

as the user has picked the wrong answer. 

In cell D12, type in the following IF statement: =IF(D9=1,"Please choose your 
answer from the list",IF(D9=””,”Please choose your answer from the 

list”,IF(D10=0,"Well done","Sorry, that's wrong")) 
This is the same as the previous statement, but it refers to question 2. 

You then need to set up another sheet that the student will see.  Click on Sheet 1 
at the bottom of the spreadsheet. 

You can use WordArt to create more interesting text.   

Go to View, Toolbars and Drawing to bring up the toolbar with the WordArt icon on 
it.  

Click on the WordArt icon.  This will bring up the WordArt Gallery.  If you 
double-click on one of the styles it will then bring up a box asking you to 

put your text in.  You can change the font type and size in this box.   

Type in Questions and click on OK, then click and drag the word to the top left-hand 

corner of the spreadsheet.    To resize the word you need to click on the word and 
then use the double-headed arrow which appears if you point the mouse over one 

of the corner boxes.  Resize the word so it takes up cells A1 to B2.   

Click on another part of the spreadsheet to make sure that the word ‘Questions’ is 
not highlighted anymore, and then click back onto the WordArt icon.  Double click 

on a style again and type in Answers and click on OK, then click and drag the word 

about halfway along the top of the spreadsheet.  Resize the box so it takes up cells 
E1 to F2. 

Underneath the word ‘Questions’ in cell A4 type in the first question What’s the 

French word for house? and press return.  If you want to change the font colour, 
click back onto cell A4 and go up to the Format menu, choose Cells, click on the 

Font tab at the top and choose a colour in the box underneath Color and click on 
OK. In cell A6 type in the second question What’s the German word for house? and 

press return.  Again you can choose a different font colour. 

You will then have to set up the box where the students

choose their answers. 

Go to View, Toolbars, Forms to bring up the Form toolbar. 

Right click on the Combo Box and choose Format Control
from the menu.  This will bring up the box shown. 

Click on the Combo Box to select it. Hold down the Alt key

and use the mouse to draw a box around cells E4 to G4.
The Alt key aligns the box with the cell gridlines.
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Click on the red box to the right of 

Input range.  This is where you specify 

the information previously set up in 

Sheet 1. 

Click on Sheet 2 at the bottom of the 

spreadsheet and highlight cells C2 to 
C6. This will provide the information 

for the list. 

Click back onto the red box to return 
to the Format Control dialogue box. 

Click on the red box to the right of Cell 
link and click on Sheet 2 again, but 

this time click on cell C9.  This box will 

show what the student has chosen. 

Click on the red box again to return to 
the Format Control dialogue box. 

In the Drop down lines box type in 5 
as there are only 5 different answers.  This can be increased if more choices are 

added.  Click in the 3D shading box to make the box look more impactual and click 
on OK. 

Choose the Combo Box again from the Form toolbar.  Hold down the Alt key and 

draw a Combo Box on the spreadsheet around cells E6 to G6.   

Right click on the Combo Box and choose Format Control from the menu.  Click on 

the red box to the right of Input range and click on Sheet 2 and highlight cells D2 
to D6.  Click on the red box to return to the Format Control dialogue box.   

Click on the red box to the right of Cell link and click on Sheet 2 again and click on 

cell D9.  Click on the red box again to return to the Format Control dialogue box. 

In the Drop down lines box type in 5 again.  Click in the 3D shading box and click 
on OK. 

In cell I4 type =Sheet2!C12 
This will tell the student whether Question 1’s answer is right or wrong. 

In cell I6 type =Sheet2!D12 
This will tell the student whether Question 2’s answer is right or wrong. 

To make the “Well done” or “Sorry, that’s wrong” stand out more, you could apply 

conditional formatting so that they appear in a different colour. 

Click on cell I4.  Go to the Format menu and choose Conditional Formatting. 

Click on the arrow next to the box that says “between”, and choose “not equal to” 
and in the box next to it, type =”Well done”  Click on the Format button and under 
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Font style choose Bold from the drop-down list.  Under Color, pick a colour from the 

drop-down list (for example red) and click on OK.  This takes you back to the first 
box.   

Click on the Add>> button.  Under Condition 2 click on the arrow next to the box 

that says “between”, and choose “equal to”.  In the box next to it type in =”Well 
done”.  Click on the Format button and under Font style choose Bold from the drop-

down list.  Under Color, pick a different colour (for example blue) and click on OK.   
The first box should appear again with two conditions in it as shown.  Click on OK. 

Click on cell I6 and 
repeat the process 

under the Format 
menu.   

If the student picks the 

correct answer “Well 
done” will appear in 

blue emboldened text.   

Any other text will 
appear in red emboldened text. 

If you want the same formatting for the cells you can use Format Painter to 

copy the format from cell I4 to cell I6.  Click on I4 then click on the Format 
Painter icon on the toolbar and then click on cell I6.   

If you want you can insert pictures by going to the Insert menu and choosing 
Picture and Clip Art.  Alternatively you could put a background colour on the sheet 

to make it look less like a spreadsheet.  Click on the square at the left-hand top 
corner between 1 and A to select the whole spreadsheet then go to Format, Cells 

and then click on the Patterns tab.  Under the cell shading you can choose a colour 
or a pattern (make sure that you can read your text over the top of the background 

colour!) and click on OK. 
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Protecting your Worksheet

If you want to make sure that nobody changes your worksheet, there are a number 

of things you can do.  Most importantly, keep a master copy! 

The easiest way to protect the worksheet is to make it read only, so the students 
can save it to another area if they want e.g. their work area or a disk, but can’t 

make any changes to the original. 
To make the worksheet read only, save it as 

normal and close it then open My Computer 

and double click on the drive the file is on (e.g. 
the A drive if it’s on a floppy).  Right click on 

the spreadsheet file and choose Properties 
from the menu that appears. 

Click in the box next to Read-only and click on 

OK.

Now anyone can open the file but if they make 

any changes they will be asked if they want to 
save the file as something else. 

If you don’t want the file read-only any more, 

just repeat the process and take the tick out of 
the Read-only box. 

You can also protect the individual worksheets 

so they can’t be changed whilst the students are working on them.  Make sure that 

the spreadsheet is NOT read-only first. 

By default, the cells in a spreadsheet are locked, but this isn’t activated until you 
protect the whole sheet.  You have to make sure, however, that the information for 

the combo box in cells C2 to D12 in Sheet 2 is NOT protected, as the student must 
be able to change it.  On Sheet 2, highlight C2 to D12, choose Format, Cells, click 

on the Protection tab and take the tick out of the Locked box by clicking in it and 
then click on OK.   

Go to the Tools menu and choose Protection and Protect Sheet.  You can set a 
password at this stage, but if you do, you need to remember it, as you can’t 

unprotect the sheet without your password.  Click on OK. 

On Sheet 1, click on the box on the top left-hand side between 1 and A to choose 
all the cells in the spreadsheet and make sure that they’ve got the Locked box 

ticked under Format, Cells and Protection.  Go to Tools, Protection and choose 
Protect Sheet.  Set a password if you want and click on OK. 

You can also hide Sheet 2 by going to the Format menu, choosing Sheet and Hide 
and repeating this on any other sheets by clicking on the sheet itself and repeating 

what you’ve just done so the students can only see Sheet 1 where they choose the 
answer.  If you want to see the sheets again, you go to the Format menu, choose 

Sheet and Unhide and then choose which sheet you want to unhide. 
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Learning Resources – Self-Testing Forms in Excel (2) 

You can also use Microsoft Excel to produce a self-testing form where the 
students have to type in their own answer, rather than choose from a list of  

answers.

Open up Microsoft Excel and save the spreadsheet. 

In cell A1 type in the first question: What’s the French word for house?

Pressing return will move to another cell.  Double click on the line between 
Column A and Column B to make the column automatically as wide as the text. 

Leave Column B blank then type in cell C1 the following formula: 

=IF(B1="","Please type your answer in Column 

B",IF(B1="maison","Well done","The correct answer is maison")) 

This tells Excel to show the message “Please type your answer in Column B” if 
there is nothing in Column B.  If the student chooses the correct answer 

“maison”, the message “Well done” will appear, otherwise the message “The 
correct answer should be maison” will  be shown. 

In cell A2 type in the second question: What’s the German word for house?

Leave Column B blank then type in cell C2 the following formula: 

=IF(B2="","Please type your answer in Column B",IF(B1="Haus","Well 
done","The correct answer is Haus")) 

Double click on the line between Column C and D to make the column as wide as 

the text. 

You would just repeat this for any other questions, typing the question in Column 
A and changing the formula in Column C to reflect the row number (i.e. B3, B4, 

B5 etc.) and changing the correct answer from Haus or maison. 

You can then change the font colour on the Columns if you want.  Click on the A 

to highlight all of Column A then go to Format, Cells, Font and choose Bold
under Font Style and choose a font colour under Color and click OK.  You could 

choose a different font colour for the column in which the students input their 
answer by clicking on B to highlight Column B and repeating what you did to 

change the font colour on Column A.   

You could change the colour of the spreadsheet but use a different colour for 

Column B to make it more obvious to the students where to type their answer in.
Click on the top left-hand square between 1 and A to highlight the whole 

spreadsheet, then click on Format, Cells, Patterns and choose a colour and 
click on OK (make sure you can still read the text). To change the colour of 

Column B, click on B to highlight the column and go to Format, Cells, Patterns,
pick a different colour and click on OK. 

You could use conditional formatting to emphasise the messages which appear 

for the correct and incorrect answers.  Click on cell C1 and choose Format and 

then Conditional Formatting.  Under Condition 1, click on the arrow next to 
between and change it to equal to.  In the next box type in =”Well done” and 

then click on the Format button.  Choose Bold under Font style and choose a 
different colour under Color (e.g. blue) and click on OK, which will take you back 

to the original box.   
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Click on the Add>> button.  Under Condition 2, click on the arrow next to 

between and change it to not equal to.  In the next box type in =”Well done”
and then click on the Format button.  Choose Bold under Font style and choose 

a different colour under Color (e.g. red) and click on OK.  You should have the 
following box on your screen. 

Click on OK again, then click on cell C2 and repeat the conditional formatting.  If 
the answer doesn’t fit in the column, double click on the line between the 

columns to make it automatically fit. 

You could also protect the spreadsheet except for Column B, which the students 

will have to change in order to input their answers. 

Click on B to highlight Column B and then choose Format, Cells and click on the 
Protection tab.  Take the tick out of the Locked box by clicking in it and then 

click on OK. 

Go to Tools, Protection, Protect Sheet and choose a password if you want 

(remember the password as you will not be able to unprotect the sheet without 
it) and click on OK. 

Your sheet should look like this and the students should just be able to change 

Column B. 

An easier way to protect the worksheet is to make it read only, so the students 
can save it to another area if they want e.g. their work area or a disk, but can’t 

make any changes to the original. 

To make the worksheet read only, save it as normal and close it then open My 

Computer and double click on the drive the file is on (e.g. the A drive if it’s on a 
floppy).  Right click on the spreadsheet file and choose Properties from the menu 

which will appear.  The following screen will appear. 
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Click in the boxes next to Read-only and click 
on OK. 

Now anyone can open the file but if they 

make any changes they will be asked if they 
want to save the file as something else. 

If you don’t want the file read-only any more, 

just repeat the process and take the tick out 

of the Read-only box and you will be able to 
make changes to the file. 


